Montador de cadeia de certificados
Cole um certificado final e seus intermediários em qualquer ordem e receba a cadeia que um servidor deve enviar: a entidade final primeiro, cada emissor depois do certificado que assinou, a raiz opcional. Os elos são feitos por identificador de chave ou por nome, as regras da RFC 5280 são conferidas no caminho (cA, keyCertSign, pathLenConstraint, validade, janelas), certificados faltantes e sobrando são nomeados, e cada assinatura é verificada no seu navegador. Nada é buscado.
Certificados e PKIRoda no seu navegador. Nada é enviado a lugar nenhum e nada é buscado, nem mesmo as URLs que os certificados nomeiam.
A validade é julgada neste instante, . Defina uma data para perguntar sobre outro dia.
Endpoint da APIGEThttps://ronutz.com/api/v1/cert-chain-builderDocumentado, não servido. Abre a especificação.
Referências
- RFC 5280: Internet X.509 PKI Certificate and CRL Profile
- RFC 8446: TLS 1.3, section 4.4.2 Certificate
- CA/Browser Forum Baseline Requirements for TLS Server Certificates, version 2.3.1 (cabforum/servercert, main)
- RFC 9155: Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2
- Let's Encrypt: Chains of Trust